Mikrotik + O2 + IPv6 (klidně s multiIPTV) nastavení

  … ano, jde to 😉

Nejdříve je potřeba překontrolova, zda je IPv6 na (A/V)DSL routeru povoleno a upravit jej do režimu bridge. Osobně mám Zyxel VMG 1312-B30B ze standardní nabídky O2.
Přihlásíme se (zpravidla) na 10.0.0.138.

Menu->Pokročilé nastavení->Povolit IPv6 -> Povolit“ class=“wp-image-66″ width=“476″ height=“237″/></figure>

<p>Překontrolujeme, zda máme pro jistotu povolené IPv6.</p>

<figure class=Pokročilé nastavení->WAN služby->ptm0.1-DATA(0/848) … musí být Bridge, jinak -> Upravit“ class=“wp-image-67″ width=“853″ height=“326″/></figure>

<p>ptm0.1-DATA(0/848) … musí být Bridge, jinak -> Upravit</p>

<figure class=Zatrhnuté Bridging
Takto je to správně

Dále pokračujeme na Mikrotik.

DHCPv6 Client … nastavení na PPPoE

Odsud získáte Váš prefix…

Do řádku „Address“ stačí ::1/64 

IPv6 Address … musíme nastavit obecně na ::1/64 nebo upravíme přímo pro náš prefix.

Nezapomenout na MTU:1460. Je potřeba nastavit max. velikost PPPoE MTU – 20.

Kód pro Mikrotik (kdo má raděj text)

# model = 951G-2HnD
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
    password=o2 use-peer-dns=yes user=o2
/ipv6 dhcp-server
add address-pool=o2 interface=bridge name=server1
/ppp profile
set *0 use-ipv6=required use-upnp=yes
set *FFFFFFFE use-encryption=default use-ipv6=default
/ipv6 address
add address=::1 from-pool=o2 interface=bridge
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 pool-name=o2 request=prefix
/ipv6 nd
set [ find default=yes ] advertise-dns=yes interface=bridge \
    managed-address-configuration=yes mtu=1460 other-configuration=yes \
    ra-interval=20s-1m

Výsledek…?

10/10 … myslím, že dobré 🙂

Oprava chyby při aktualizaci na MacOS 10.13.6


Pro aktualizaci systému MacOS (z 10.13.5 na 10.13.6) na AppStore je pak potřeba provést restart. Každý pokus o restart i o vypnutí mi však končil na úplně černé stránce jen s kurzorem, kterým se dalo pohybovat po celé „jen černé obrazovce“.

Pokoušel jsem se mnoha způsoby najít aplikaci nebo cokoliv co to způsobuje.

Opravu jsem nalezl zde (https://discussions.apple.com/thread/8466124):
– v normálně nabootovaném systému stačí otevřít Terminál (Finder->Otevřít->Utility->Terminál) a postupně napsat tyto příkazy (každý samostatně potvrdit a u těch se „sudo“ zadat administrátorské heslo):

rm -rf ~/Library/Caches/*
rm -rf ~/Library/Saved\ Application\ State/*
sudo rm -rf /Library/Caches/*
sudo rm -rf /System/Library/Caches/*
atsutil databases -removeUser
sudo atsutil databases -remove
sudo atsutil server -shutdown
sudo atsutil server -ping
sudo rm -rf /var/folders/*

Pak už jen stačilo dát restart a objevilo se nové okno s výzvou zda Restartovat nebo Restartovat a aktualizovat. Dal jsem aktualizovat a po zhruba 20 minutách bylo vše OK.

P.S.: Některé aplikace spouštěné automaticky po startu bylo nutné pustit manuálně a znovu zatrhnout volbu o puštění po startu.

Užitečné příkazy Terminálu Linux

tcpdump -vv -x -X -s 1500 -i eth0 ‚port 25‘
… vypsání všech spojení na daném rozhraní a portu (např.: eth0, port25)

w
… vypsání připojených uživatelů

history
… historie příkazů

netstat -taWp
… výpis otevřených portů a procesů, které je využívají

mailq
… vypsání čekajících mailů ve frontě Postfix

postsuper -d ALL
… vyčištění fronty mailů ve frontě Postfix

top
… vytížení paměti a procesoru procesy

landscape-sysinfo
… vyvolání souhrnu zatížení a výkonu (info po spojení SSH v Ubuntu)

uname -a
… zjištění distribuce a názvu serveru

Translate »