Mikrotik + O2 + IPv6 (klidně s multiIPTV) nastavení

  … ano, jde to 😉

Nejdříve je potřeba překontrolova, zda je IPv6 na (A/V)DSL routeru povoleno a upravit jej do režimu bridge. Osobně mám Zyxel VMG 1312-B30B ze standardní nabídky O2.
Přihlásíme se (zpravidla) na 10.0.0.138.

Menu->Pokročilé nastavení->Povolit IPv6 -> Povolit

Překontrolujeme, zda máme pro jistotu povolené IPv6.

Pokročilé nastavení->WAN služby->ptm0.1-DATA(0/848) ... musí být Bridge, jinak -> Upravit

ptm0.1-DATA(0/848) … musí být Bridge, jinak -> Upravit

Zatrhnuté Bridging
Takto je to správně

Dále pokračujeme na Mikrotik.

DHCPv6 Client … nastavení na PPPoE

Odsud získáte Váš prefix…

Do řádku „Address“ stačí ::1/64 

IPv6 Address … musíme nastavit obecně na ::1/64 nebo upravíme přímo pro náš prefix.

Nezapomenout na MTU:1460. Je potřeba nastavit max. velikost PPPoE MTU – 20.

Kód pro Mikrotik (kdo má raděj text)

# model = 951G-2HnD
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
    password=o2 use-peer-dns=yes user=o2
/ipv6 dhcp-server
add address-pool=o2 interface=bridge name=server1
/ppp profile
set *0 use-ipv6=required use-upnp=yes
set *FFFFFFFE use-encryption=default use-ipv6=default
/ipv6 address
add address=::1 from-pool=o2 interface=bridge
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 pool-name=o2 request=prefix
/ipv6 nd
set [ find default=yes ] advertise-dns=yes interface=bridge \
    managed-address-configuration=yes mtu=1460 other-configuration=yes \
    ra-interval=20s-1m

Výsledek…?

10/10 … myslím, že dobré 🙂

3 komentáře

  1. Postupoval jsem podle návodu a vše funguje až na DNS server, kde mi to dle testu tvrdí, že nemá přístup k IPv6 nebo je špatně nakonfigurovaný. V PPP profilech je třeba vytvořit dva nové, chápu-li to správně? Díky.

  2. Chtěl bych poprosit o radu – postupoval jsem podle návodu, vše funguje, ale když dám test IPv6, tak mi to vyhodí chybu s tím, že DNS server nemá přístup k IPv6 nebo není nakonfigurován. V PPP profilech je potřeba vytvořit dva nové s rozlišným nastavením, chápu-li to správně? Díky.

  3. Hledám, jak nastavit Mikrotik jako DHCPv6 server pro LAN port, aby si počítače brali adresu a DNS servery z DHCP serveru. Tady ten příklad vypadá, že na WAN portu (pppoe-out1) je nastaven DHCp klient prefix delegation, tedy že O2 pošle zákaznický prefix v DHCP. V LAN síti (bridge) pak používáte automatickou konfiguraci nebo i DHCPv6? Já mám WAN port řešený jinak a DHCP klient na něm neběží. Na LAN portu mám DHCP server s poolem /64, ale Mikrotik na DHCP žádosti nereaguje. Možná funguje jen ve spojení s prefix delegation, ale nikde jsem to nenašel jasně popsané.

Napsat komentář: Martin Zrušit odpověď na komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *

Translate »